Federal Cybersecurity Failures Include 48-Year-Old Software

“Federal Cybersecurity Failures Include a 48-Year-Old System Few People Knew How to Use,” by Alyssa Newcomb, fortune.com

“Federal agencies fail to follow basic computer security standards including relying on a 48-year-old system for critical work, leaving the government vulnerable to hackers, according to Congressional report published on Tuesday.”

— Read The Article

Posted in: